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Foreword 

This user's manual describes the Symbol Editor’s handling precautions, functions, operating 
procedures, and other important information for use of the software. To ensure correct use, 
plea120 
110 
se read this manual thoroughly during operation. After reading this manual, keep it in a convenient 
location for quick reference in the event a question arises during operation. Furthermore, for the 
handling precautions, functions, and operating procedures of the DL series, or for the handling and 
operating procedures of Windows, please see the manuals for those respective products.  

Notes 
• The contents of this manual are subject to change without prior notice as a result of 

improvements in performance or functionality. Display contents illustrated in this manual may 
differ slightly from what actually appears on your screen.  

• Every effort has been made in the preparation of this manual to ensure the accuracy of its 
contents. However, should you have any questions or find any errors, please contact your 
nearest YOKOGAWA representative as listed on the back cover of this manual. 

• Copying or reproduction by any means of all or any part of the contents of this manual without 
permission is strictly prohibited. 

• This software creates data files compatible with the SB5000 series and DL9500/DL9700 series.  
 

Trademarks 
• MS-DOS, Windows, and Windows NT are trademarks or registered trademarks of Microsoft 

Corporation in the United States and/or other countries.  
• Adobe and Acrobat are trademarks of Adobe Systems incorporated.  
• CANdb and CANdb++ are registered trademarks of Vector Informatik Gmbh in Germany.  
• The company and product names used in this manual are not accompanied by the trademark or 

registered trademark symbols (TM and ®).  
• Other company and product names are trademarks or registered trademarks of their respective 

companies. 
Revisions 

• 1st Edition  January, 2008 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

All Rights Reserved, Copyright © 2008 Yokogawa Electric Corporation 
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    Product Overview 
 

Functions 
 

 

Physical value symbol definition 
data for serial bus analysis 
 + 
Logic symbol definition data 

Symbol 
definition file1

Logic symbol definition data

Save 
Load 
Edit 

Load 
reference file 

1. The following are included in symbol definition files. 
   • Physical value symbol definition data for serial bus analysis 
   • Logic symbol definition data 

 
Create and Edit Physical Value Symbol Definition Files for SB5000 Series Serial Bus 
Analysis  

You can create physical value symbol definition files for serial bus analysis.  
Created files can be saved for use on the SB5000.  
Saved files can be loaded and edited.  
 

Import CANdb Files 
You can load CANdb files and create physical value symbol definition files for the SB5000.  
 

Create and Edit Logic Symbol Files for the SB5000, DL9700, and DL9500 Series  
You can create logic symbol definition files that can be used on the SB5000, DL9700, and DL9500 
series. Created files can be saved for use on the SB5000, DL9700, and DL9500 series. Saved files 
can be loaded and edited.  
 

Search for Registered Messages 
You can search created or loaded data for registered messages.  
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System Requirements 
 
Personal Computer  

A personal computer (PC) is required that is running Windows 2000 SP4 or later, Windows XP SP2 
or later, or Windows Vista, having a Pentium 4, 2 GHz or faster CPU and 512 MB or more (1 GB or 
more recommended) of memory.  
 

Display 
Display: SVGA/XGA (XGA or better recommended) 
Colors: 65536 or more 
The display must be compatible with Windows 2000 SP4 or later, Windows XP SP2 or later, or 
Windows Vista.  
 

Mouse 
A mouse that is compatible with Windows 2000 SP4 or later, Windows XP SP2 or later, or 
Windows Vista.  
 
 

DL Series and Firmware Able to Load Symbol Definition Files (*.sbl)  
DL9700/DL9500 series: Version 4.00 or later  
SB5000 series: All firmware versions 
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Important Information for Users 
 
Disclaimers 

By downloading and installing this software, the customer agrees to all of the following disclaimers.  
• Yokogawa bears no liability for any problems occurring as a result of downloading or installing 

this software.  
• Yokogawa bears no responsibility for any damage caused directly or indirectly as a result of using 

this software.  
• This software is provided free of charge, however no unlimited warranty against software defects 

exists, nor is any claim made that the product is free of all defects whatsoever. Also, Yokogawa is 
not always able to repair defects (“bugs”) in, or respond to questions or inquiries about this 
software.  

• Yokogawa reserves all rights to this software, including but not limited to all property rights, 
ownership rights, and intellectual property rights.  

 
Usage Precautions 

• If the PC enters a standby mode (a feature that may have been installed), this software may not 
be able to run continuously. Be sure to turn off the PC’s standby mode. 
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Installing and Uninstalling the Software 
 

Installing  
1. Download the Symbol Editor from the Yokogawa Web site. Save the file to an appropriate 

location on the PC.  
2. The downloaded file is compressed. Decompress the file using a suitable decompression 

program (such as WinZip). The Symbol Editor folder is created.  
 
 
Uninstalling  

1. Delete the Symbol Editor folder.  
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 1.1 Starting and Exiting the Program 
 

Starting the Program 
 Double-click Symbol Editor.exe to start the program. The window below is displayed.  
 

 
 

Loads files as reference 
data.  

 Edits definition data.  

 
 
 
 
 
 

Exiting the Program 
 

 
Click File > Exit.  
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 1.2 Basic Operations in the Main Screen 
 

 
 
 
 
 
 
 
 
 
 
 
 

 

Selects the data to edit 
• CAN 
• LOGIC 

Searches for messages 
registered in the list 

Opens the 
Help window

Reference: Loads CANdb (*.dbc) and symbol 
definition files (*.sbl) 

Delete: 
Deletes messages from the 

definition list 

Save: 
Saves symbol 

definition files 

Add: 
Adds messages to 

the definition list 

View: Displays messages 

Sorting 
Click a column title to sort by 
that column. Toggles between 
ascending  and descending 

d

Edit: Edits registered messages

New: Creates new messages

Open: Loads symbol definition files (*.sbl)
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 2.1 Loading Reference Files  
 

1. In the Reference list, click , or click File > Reference to display the Open dialog box.  
 
 

 
 

2. Type the name of file you wish to open in the File name box or select one from the list, then click 
Open. The messages are displayed in the reference list.  

 
             _________________________________________________________________ 

Note:  
• If the edit mode is CAN, CANdb (*.dbc) and symbol definition (*.sbl) files can be loaded.  
• CANdb files can contain up to 5000 messages.  
• If the edit mode is LOGIC, symbol definition (*.sbl) files can be loaded.  

             _________________________________________________________________ 
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2.2  Displaying Definitions  
 

1. In the reference list, select a message then click , or click Edit > View to display a dialog box 
for displaying definitions.  

 

  
CAN                                     LOGIC 

 
_________________________________________________________________ 
Note:  

• The contents of the dialog box differs depending on the edit mode.  
• The contents of messages do not change.  
 
CAN 
• The usage of bits within the message is shown to the right of the Start bit and Bit count 

boxes.  
 Meanings of colors 
  White: Unused bit 
  Green: Bit used by signal in question 
  Gray: Bit used by other signal (4 gradations express multiple signals) 

_________________________________________________________________ 
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 2.3 Adding Definitions  
 

1. In the reference list, select a message then click , or click Edit > Add. A message is added 
to the definition list.  

 

 
 
 
             _________________________________________________________________ 
             Note:  

• You can select one message or multiple messages to add at a time. To select multiple 
messages, hold down the Ctrl key while clicking each message. When multiple 
messages are selected, all are added to the definition list together.  

• You can add definitions by dragging messages from the reference list to the definition 
list.  

• Up to 500 messages can be registered in the definition list.  
• CANdb data of value type Float cannot be added to the definition list.  

             _________________________________________________________________ 
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 3.1 Loading Definition Files  
 

1. In the definition list, click , or click File > Open to display the Open dialog box.  
 
 

 
 
 
 

2. Type the name of file you wish to open in the File name box or select one from the list, then click 
Open. The messages are displayed in the definition list.  

 
 
 

____________________________________ 
               Note:  

            • Symbol definition files (*.sbl) are loaded.  
               ____________________________________ 
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 3.2 New Definitions  
 

1. In the definition list, click , or click Edit > New to display the dialog box for new definitions.  
 

  
CAN                                     LOGIC 
                 ________________________________________________________________ 
                 Note:  

• The contents of the dialog box differs depending on the edit mode.  
• The characters that can be used in the Message name, Signal name, and Unit boxes are:  
 0 to 9, A to Z, a to z, %, _, (, ), -, and / 
• You may not enter a message name that is already assigned to a message. 
• Up to 500 messages can be registered in the definition list.  
CAN 
• You may not enter a signal name that already exists within a message.  
• Message ID setting range 
 If Frame format = STD, 0 to 2047 (7FF hex) 
 If Frame format = XTD, 0 to 536870911 (1FFFFFFF hex) 
• The byte count setting range is 0 to 8. 
 If 0, the signal cannot be set. 
• The signal start bit setting range is 0 to (byte count × 8-1). 
• The signal bit count setting range is 1 to (byte count × 8 – start bit).  
• The maximum number of characters that can be used in the Message name, Signal name, 

and Unit boxes is 32.  
• When creating a new definition, you can copy previously defined message and signal 

settings from the Message name, Message id, and Signal name lists.  
• The usage of bits within the message is shown to the right of the Start bit and Bit count 

boxes.  
 Meanings of colors 
 White: Unused bit 
 Green: Bit used by signal in question 
 Gray: Bit used by other signal (4 gradations express multiple signals) 
 You can click or drag to select.  
LOGIC 
• You cannot create an identical bit pattern to one that already exists in the same group.  
• The maximum number of characters that can be used in the Message name box is 16.  

                _________________________________________________________________ 
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 3.3 Editing Definitions  
 

1. In the definition list, select a message and click , or click Edit > Edit to display the dialog box 
for editing definitions.  

 

  
CAN                                   LOGIC 
 
 

For precautions when editing definitions, see "Note” in section 3.2.  
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 3.4 Deleting Definitions  
 

1. In the definition list, select messages and click , or click Edit > Delete. The selected 
messages are deleted from the definition list.  

 
 

 
 

 

 

________________________________________________________________ 
Note: 

• You can select one message or multiple messages to delete at a time. To select multiple 
messages, hold down the Ctrl key while clicking each message. When multiple messages 
are selected, all can be deleted from the definition list together.  

________________________________________________________________ 
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 3.5 Saving Definitions 
 

1. In the definition list, click , or click File > Save to display the Save As dialog box.  
 

 
 
 

2. In the File name box, type the name under which you wish to save the file or select a file from the list, 
then click Save. The contents of the definition list are saved to the file.  

 
 
 
 
 

____________________________________ 
Note:  
  • You can save symbol definition files (*.sbl).  
____________________________________ 
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 4.1 Searching Messages  
 

1. Click , or click Edit > Search to display the Find dialog box.  
 

 

 
 

2. Enter the string you wish to search for in the Find what box, then click Find. The matching location in 
the specified list is selected and displayed.  
 
 
 

______________________________________________________ 
Note:  
 • You can select from a history of previously entered search strings in the list.  
______________________________________________________ 
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 4.2 Selecting or Sorting All Items in the List  
 

• Selecting All Items in the List 
 
1. Click Edit > All to select all items in the active list.  

 
 
 
 

• Sorting All Items in the List 
 

1. Click a column title to sort. Toggles between ascending and descending sort order.  
 
 

 

Column titles 

_________________________________________________________ 
Note:  
  • When sorted, ▲ (ascending) or ▼ (descending) is indicated in the title.  
_________________________________________________________ 
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 5 Other Functions 
 

• Version Information 
 

1. Click Help > About to display version information.  
 

 
 
 

• User's Manual 
 

1. Click , or click Help > User’s Manual to display the user’s manual.  
 

________________________________________________________________ 
Note:  

• Adobe Reader by Adobe Systems is required to open PDF files. You can download 
Adobe Reader from the following Web page. 

 http://www.adobe.com/jp/ 
________________________________________________________________ 

 
 
 

• Viewing the Yokogawa Electric Web Site 
 

1. Click Help > YOKOGAWA Web site > Test & Measurement, or click Help > YOKOGAWA Web 
site > Symbol Editor. The Yokogawa Web site appears.  
 

________________________________________________________________ 
Note:  

If your PC is connected to the Internet, the Yokogawa Web site is displayed.  
Test & Measurement: The Yokogawa Test & Measurement home page is displayed.  
Symbol Editor: The product page is displayed, containing the latest product 

information including information on version upgrades.  
________________________________________________________________ 
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